Cisco 3850 Catalyst Sample Network Switch Configuration
Release Notes
Feel free to make the appropriate changes to fit your port count and network environment.
!
! Last configuration change at 17:02:39 UTC Mon Mar 9 2020
!
version 16.6
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname Switch
!
!
vrf definition Mgmt-vrf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
no logging console
!
no aaa new-model
switch 1 provision ws-c3650-24pd
!
!
!
!
!
no ip domain lookup
!
!
!
ip igmp snooping last-member-query-interval 100
ip igmp snooping querier address 10.10.2.253
ip igmp snooping querier
ip igmp snooping vlan 999 querier address 10.10.2.253
ip igmp snooping vlan 999 querier query-interval 30
ip igmp snooping vlan 999 immediate-leave
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-3054622113
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3054622113
revocation-check none
rsakeypair TP-self-signed-3054622113
!
!
crypto pki certificate chain TP-self-signed-3054622113
!
!
!
diagnostic bootup level minimal
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
!
redundancy
mode sso
!
!
transceiver type all
monitoring
lldp run
!
!
class-map match-any system-cpp-police-topology-control
description Topology control
class-map match-any system-cpp-police-sw-forward
description Sw forwarding, L2 LVX data, LOGGING
class-map match-any system-cpp-default
description DHCP Snooping, EWLC control, EWCL data
class-map match-any system-cpp-police-sys-data
description Learning cache ovfl, Crypto Control, Exception, EGR Exception, NFL SAMPLED DATA, RPF Failed
class-map match-any system-cpp-police-punt-webauth
description Punt Webauth
class-map match-any system-cpp-police-l2lvx-control
description L2 LVX control packets
class-map match-any system-cpp-police-forus
description Forus Address resolution and Forus traffic
class-map match-any system-cpp-police-multicast-end-station
description MCAST END STATION
class-map match-any system-cpp-police-multicast
description Transit Traffic and MCAST Data
class-map match-any system-cpp-police-l2-control
description L2 control
class-map match-any system-cpp-police-dot1x-auth
description DOT1X Auth
class-map match-any system-cpp-police-data
description ICMP redirect, ICMP_GEN and BROADCAST
class-map match-any system-cpp-police-stackwise-virt-control
description Stackwise Virtual
class-map match-any non-client-nrt-class
class-map match-any system-cpp-police-routing-control
description Routing control
class-map match-any system-cpp-police-protocol-snooping
description Protocol snooping
class-map match-any system-cpp-police-system-critical
description System Critical and Gold
!
policy-map system-cpp-policy
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
vrf forwarding Mgmt-vrf
no ip address
speed 1000
negotiation auto
!
interface GigabitEthernet1/0/1
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/2
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/3
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/4
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/5
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/6
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/7
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/8
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/9
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/10
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/11
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/12
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/13
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/14
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/15
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/16
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/17
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/18
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/19
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/20
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/21
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/22
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/23
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/24
switchport access vlan 999
switchport mode access
switchport block multicast
no ip igmp snooping tcn flood
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface TenGigabitEthernet1/1/3
!
interface TenGigabitEthernet1/1/4
!
interface Vlan1
no ip address
!
interface Vlan999
ip address 10.10.2.253 255.255.255.0
!
ip forward-protocol nd
ip http server
ip http secure-server
!
!
!
!
control-plane
service-policy input system-cpp-policy
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
!
!
!
!
!
!
end